Environmental requirements 1

The basic environment requirements are met to run the framework. The EasySwoole framework is very simple to the environment. It only needs to meet the conditions for running Swoole extension, and the PHP version is above 7.1.

Basic operating environment

  • Guaranteed PHP version is greater than or equal to 7.1
  • Guaranteed Swoole extended version is greater than or equal to 4.4.12
  • Need any version of pcntl extension
  • Use Linux / FreeBSD / MacOS These three types of operating systems
  • Use Composer as a dependency management tool

Refer to the suggestions below, they are not required, but help to use the framework and develop more efficiently.

  • Use Ubuntu14 / CentOS 7.0 or higher operating system


  • QQ exchange group

    • VIP group 579434607 (this group needs to pay 599 RMB)
    • EasySwoole official group 633921431 (full)
    • EasySwoole official two groups 709134628 (full)
    • EasySwoole official three groups 932625047 (full)
    • EasySwoole official four groups 779897753 (full)
    • EasySwoole official five groups 853946743 (full)
    • EasySwoole official six groups 524475224
  • Business support:

    • QQ 291323003
    • EMAIL admin@fosuss.com
  • Author WeChat

  • Donation Your donation is the greatest encouragement and support for the Swoole project development team. We will insist on development and maintenance. Your donation will be used to:

    • Continuous and in-depth development
    • Document and community construction and maintenance
  • EasySwoole The document uses GitBook as the document writing tool. If you find that the document needs to be corrected or supplemented during use, please fork project document warehouse, modify and supplement, submit Pull Request and contact us